Career Site Errors

Incident Report for Radancy Talent Acquisition Cloud

Resolved

Our team has identified and resolved the core issue, and systems are now operating as expected. While the main problem has been addressed, we are continuing to monitor performance closely.

If you experience any lingering issues, please don’t hesitate to reach out to our support team by visiting the Radancy Support Center to report the issue: https://support.radancy.net/hc/en-us/requests/new.

Thank you,
Radancy Global Customer Support
Posted Mar 06, 2025 - 10:22 EST

Update

Please be advised that our team continues to actively investigate this issue, and is working to identify the root cause. We appreciate your patience and will share another update in 1 hour.

If you have any questions or concerns regarding this notification, please visit the Radancy Support Center to submit a request: https://support.radancy.net/hc/en-us/requests/new.
Posted Mar 06, 2025 - 09:38 EST

Update

We are continuing to investigate this issue and appreciate your patience as our teams work toward a resolution. We are actively monitoring and will provide another update in 1 hour.

If you have any questions or concerns, please visit the Radancy Support Center to submit a request: https://support.radancy.net/hc/en-us/requests/new.

Thank you,
Radancy Global Customer Support
Posted Mar 06, 2025 - 08:35 EST

Investigating

Please be advised that we are currently experiencing issues with some career sites intermittently displaying errors and we are actively working to resolve. We will provide an update within 1 hour.

If you have any questions or concerns regarding this notification, please visit the Radancy Support Center to submit a request: https://support.radancy.net/hc/en-us/requests/new.

Thank you,
Radancy Global Customer Support
Posted Mar 06, 2025 - 07:47 EST
This incident affected: Talent Acquisition Cloud (Career Site & CMS).