Hiring Events - Scheduled Maintenance - 12/18/2025

Scheduled for Dec 18, 21:00 - 22:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Dec 12, 2025 - 11:47 EST

Scheduled

Please be aware that Radancy will be performing scheduled Hiring Events platform maintenance on Thursday, December 18th from 9:00 PM EST to 10:00 PM EST. During this window, there is no expected downtime.

If you need assistance during this maintenance window, please visit the support center to submit a request: https://support.radancy.net/hc/en-us/requests/new.
Posted Dec 12, 2025 - 11:46 EST
This scheduled maintenance affects: Talent Acquisition Cloud (Hiring Events).