Hiring Events - Booth Editing Issue

Incident Report for Radancy Talent Acquisition Cloud

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 09:11 EDT

Identified

We have identified an issue where hidden booth settings may unintentionally carry over when editing other booths. This only affects admins working between hidden and non-hidden booths. Live and scheduled events are not impacted and continue to operate as expected. As a workaround, please refresh your browser before making changes to your booth. A fix has been developed and will be released this Saturday, August 23rd during our maintenance window.
Posted Aug 20, 2025 - 17:04 EDT
This incident affected: Talent Acquisition Cloud (Hiring Events).